阿里云虚拟机怎么更换PHP版本,需要注意什么?

11个月前 ( 12-17 ) 2381阅读 0评论

很多时候我们在ZB程序后台(或者其他程序),在启用某些功能的时候,可能会有如下提示“PHP版本太旧”,这时怎么回事呢?因为某些功能不兼容之前的PHP,或者说某些程序设定需要开启更高的php版本才能使用,所以我们得升级php版本,其实在当今社会互联网程序的迭代升级可谓是日新月异,我们唯一能做的只是跟上时代的步伐,不能太落后。。。

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第1张

简单说下阿里云虚拟机怎么更新PHP版本:

  • 首先我们需要登录阿里云账号,嗯嗯,我知道这是废话,,,登录之后点击右侧“控制台”,如图:

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第2张

  • 然后可以看见最近使用的产品,如果有云虚拟主机直接点击打开就行,如果没有,在下方“已开通的产品”中查找云虚拟主机,找到之后点击,,如图:

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第3张

  • 在新弹出的页面可以看见目前开通的主机,找到需要更改php版本的主机,点击右侧“管理”,如图:

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第4张

  • 然后进入到阿里云主机管理平台,点击如图菜单“高级环境设置”,在这里可以修改php的版本php.ini的设置,今天只更改版本,不涉及修改php.ini,所以我们点击php版本设置:


阿里云虚拟机怎么更换PHP版本,需要注意什么? 第5张

  • 打开之后如图,(未设置的话可能是5.2也可能是5.3,这都不重要,重要的是我们要更改更高的版本)

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第6张

  • 就目前而言,主流的程序均已支持php7.0+,当然部分程序可能不支持7.3,不过不要紧,阿里云主机没有给出7.3的版本,我们一般按照程序所需即可,比如程序提示需要php7.0及以上版本:

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第7张

  • 此时我们将云虚拟机的php版本修改成7.0,如图:

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第8张

当我们把php版本设置7.0的时候,顶部有一个提示“PHP版本设置为5.3及以上,需在重置数据库密码时,将数据库加密模式设置为41位加密!”,很简单,就是说在我们更改了php版本的时候,需要连同把mysql数据库的加密模式修改为“41位”,好的,提示已经知晓了,那么就先保存设置。然后点击左侧菜单“数据库信息”,然后点击右侧“重置密码”(温馨提示:修改数据库密码可以跟原密码一样,但是为了安全起见,在修改密码之前,最好备份下数据库,点击管理进入mysql数据库进行备份,这个不赘述备份,我之前写过怎么备份数据库,需要的自己前往查看:“ZBP备份文章”,查看备份mysql数据库文件。

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第9张

  • 弹出数据库密码重置,选择加密模式41位,新密码最好跟之前的一样,否则就得及时修改网站程序中的数据库连接串,以免导致网站无法访问。修改之后点击确定就可以了,如图:

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第10张

  • 最后,防止出现莫名奇怪的故障建议重启站点服务,点击站点信息,点击如图“停止站点”然后重新启用站点。

阿里云虚拟机怎么更换PHP版本,需要注意什么? 第11张

  • 好了到目前为止,阿里云虚拟机更换php版本的图文教程就完成了。

写个文章一小时,也是没谁了,为什么,想知道么?因为一步都不能差,差一步都会有人问怎么跟你的教程不一样,哦,,,说到这想起来了事,图中的主机平台是阿里云新版,旧版不是酱婶儿的,如果登录之后跟图中不一样,请查看首页顶部提示“公告:新版控制台提供更完善的功能,更好的体验,邀您体验新版控制台”,好了。下班回家!

文章版权声明:除非注明,否则均为李洋个人博客原创文章,转载或复制请以超链接形式并注明出处。

发表评论

表情:
评论列表 (暂无评论,2381人围观)

还没有评论,来说两句吧...

取消
支付宝二维码
支付宝二维码
微信二维码